iERP.ai studio technical requirements

iERP.ai Studio platform is available for all 3 major operating systems (Windows, MacOS and Linux).

By default CPU only version of studio is distributed. On modern CPU performance of CPU version is perfectly suitable for production deployment with response times with less than 5ms latency.

For specific reasons or large data sets, some customers may require GPU version of the platform which is available upon request.

Windows

Windows app version: 1.1

MacOS

MacOS app version: 1.1

Linux

Linux app version: 1.1

Arm Linux

In development

Operating system requirements

* Windows 7 and later are supported, older operating systems are not supported (and do not work).
* Both x86 and amd64 (x64) binaries are provided for Windows.(Please note, the ARM version of Windows is not supported for now.)
* 4GB memory minimum (data sources are fully loaded into memory therefore more memory may be required)

iERP.ai Studio requirements (CPU version)

* Any Intel CPU produced after 2011 with AVX instruction set
* Any AMD CPU produced after 2011 with AVX instruction set

iERP.ai Studio requirements (GPU version)

* NVIDIA® GPU card with CUDA® Compute Capability 3.5 or higher.
* NVIDIA® GPU drivers —CUDA 10.0 requires 410.x or higher.
* CUDA® Toolkit —TensorFlow supports CUDA 10.0 (TensorFlow >= 1.13.0)
* CUPTI ships with the CUDA Toolkit.
* cuDNN SDK (>= 7.4.1)

Operating system requirements

* Minimum OS X version supported is OS X 10.9 or higher
* Only 64bit binaries are provided for OS X

iERP.ai Studio requirements (CPU version)

* Any Intel CPU produced after 2011 with AVX instruction set
* Any AMD CPU produced after 2011 with AVX instruction set

iERP.ai Studio requirements (GPU version)

* NVIDIA® GPU card with CUDA® Compute Capability 3.5 or higher.
* NVIDIA® GPU drivers —CUDA 10.0 requires 410.x or higher.
* CUDA® Toolkit —TensorFlow supports CUDA 10.0 (TensorFlow >= 1.13.0)
* CUPTI ships with the CUDA Toolkit.
* cuDNN SDK (>= 7.4.1)

Operating system requirements

* The prebuilt ia32(i686) and x64(amd64) binaries built on Ubuntu 12.04
* the arm binary built is not available.

iERP.ai Studio requirements (CPU version)

* Any Intel CPU produced after 2011 with AVX instruction set
* Any AMD CPU produced after 2011 with AVX instruction set

iERP.ai Studio requirements (GPU version)

* NVIDIA® GPU card with CUDA® Compute Capability 3.5 or higher.
* NVIDIA® GPU drivers —CUDA 10.0 requires 410.x or higher.
* CUDA® Toolkit —TensorFlow supports CUDA 10.0 (TensorFlow >= 1.13.0)
* CUPTI ships with the CUDA Toolkit.
* cuDNN SDK (>= 7.4.1)